GUIApp Knowledge Base 3/30/98





Conventions:





GUIApp menu items are referred to in the following way:





Settings>Rendering>Render Cache Options  means pick the Rendering under the Settings menu on the GUIApp menu bar, and then pick Render Cache Options from the sub menu.





Move the 'Max Objects' slider under 'Multiple Object Caching' in RenderCache Settings indicates settings to change on a windowed dialogue (in this case, the Render Cache Settings dialogue which we opened in the previous example).





Setup





Working Directory:


Whether you are running the CM release (this is the official name for the shortcut named "Current GUIApp."  CM = Configuration Management system), or whether you are running a local copy, GUIApp needs to run out of the directory C:\JP2_PC.  Normally this should never affect you because the Current GUIApp is already set up to use that as the working directory , but if you accidentally delete it or go to run GUIApp on a computer that hasn't been set up, you will have to create it and set any new GUIApp shortcuts to point there (right click on theicons, choose the Shortcut tab, and set the "Start In" directory to be C:\JP2_PC).





Display Settings:


GUIApp will only run if your desktop is set to 15 bit (32768 colors) or 16 bit (65536 colors).  A lot of MAX accelerators only support 32 bit color: if you use one you will need to run GUIApp on a different computer.





Options.txt/lastopt.txt:


Every time you exit GUIApp, a file called lastopt.txt gets created in your C:\JP2_PC directory.  This records some of the changes you have made to GUIapp settings (but not all). If you want to have those changes next time you run GUIApp, rename lastopt.txt to options.txt.  You can open up options.txt with Notepad and change some settings in it by hand: you can set clut colors (the lighting colors for all objects) , or have it always open a set of groffs or a particular scene file, for instance.  





Warning: be careful using options.txt: you can easily do something like turn off bumpmap loading, forget you have an options.txt, and then drive yourself crazy wonder why you aren't seeing any bumpmaps on any objects.  It is recommended that you either not using options.txt or delete all the other entries in the file except the ones you know you want to change to avoid any unintentional problems.





File Types





Loading:


GUIApp can load Groffs (.grf) or Scene Files (.scn).  Groffs are the files you make when you use the exporter in MAX.  Scenes are a prototype save game format: they load groffs, but they also keep track of other changes such as AI state of dinosaurs, positions of objects, gun ammo, trigger status, and most importantly, whether you have built a spatial partition.  Partitions are the subject of another document, but having one is necessary to allow all the systems of the game to run at a reasonable speed.  When you are working with areas above a few hundred objects, you will always want to be loading a scene file with an optimized partition, in order to get a usable framerate.





Load a groff by choosing Add>Add Object and using the file window to navigate around the network.





Load a scene by choosing Game>Open and using the file window to find the file you're looking for.





Saving:





GUIApp can write Scene Files (.scn) and Groff Text files (.txt or any other extension you want).  As described above, a Scene saves a lot of current information about which groffs you have loaded (you can load in two groffs, save a scene, and when you reload it you will get both groffs back), and various other game state information.





Choose Game>Save or Game>Save As to write a scene file, and use the file window to point to where you want to save it.  You can save it anywhere on the network.  





Warning: if you have previously loaded a scene file and pick Game>Save, you will overwrite the scene file you just loaded with no confirmation.  It is recommended to always use Save As.  





Additional Warning: Scene files are hardcoded with the location of the groff files they loaded.  This means if you move the groffs the scene file is referencing, you can't load that scene file again: you must load the groffs and make a new scene file.  This is to be fixed soon (3/28).





Groff Text files are used to convey the position, orientation, and scale of information back to MAX through use of the Load Groff Text script.  It writes out a text file containing that information about every object in the scene which the script can read back in.  Name it whatever you want, but it is recommended you save it in the same directory as the MAX file it is associated with to avoid losing it.





Errors





When GUIApp stops and pops up an error window, one of two different things has happened: either it has asserted, which means that the code found a known problem and stopped loading or running, or it has crashed, which means that an unknown problem has caused the game to stop working.  It is very important to know the difference between the two: programmers can usually track down the cause of assertions fairly easily, and some of them are self-explanatory enough that you can figure out why they happened without consulting anyone, whereas crashes sometimes need deeper investigation and may possibly have to be handed to QA (the Quality Assurance department, our playtesters) to hunt down, especially those that occur when you have been wandering around for a while 





Assertions give a larger window which says Assertion failed! at the top and has three buttons at the bottom: click on Abort to stop running GUIApp, or click on Retry which means GUIApp will attempt to keep running.  After certain assertions, GUIApp may become unstable, however, and continuing to run it may lead to an actual crash.





Crashes will often give a small window which says Unhandled Exception and lists a memory address, or one which says The program has performed an illegal operation and must be shut down.  Sometimes they will even just make the GUIApp window close altogether, or lock up your machine (usually the latter only happens under Win95).








 Controls





GUIApp has two main modes: Edit mode and Play mode.  Press F8 to switch between the two.  In Edit mode, you can use the mouse to move objects around and view or edit their properties.  In Play mode, physics and all other game systems are running in real time, and you can actually play the game.





F7 is also very important: this turns on and off image cacheing.  Sometimes you need to force the image caches to rebuild by turning them off and back on.





Here are some of the most useful keyboard and mouse commands:





Debug Movement





You can use the left and right arrow keys to left to right relative to the screen and the up and down keys to move in and out relative to the screen.  Insert and Delete rotate left and right relative to the screen, Page Up and Page Down rotate up and down relative to the screen, and + and - move up and down relative to the screen.





Space fires an extremely powerful impulse to the center of the screen.  Shift Space does the same thing in reverse: it will draw objects towards you instead of pushing them away.  Currently (3/30) the force imparted by these is so much that it will break the physics system constantly.





Player Movement





3/30: When Anne has been loaded into the scene, the controls become the following in play mode: W runs forward, S walks forward, and X moves backward, while the mouse controls the direction she is looking, and thus moving.  Holding the left mouse button allows you to move Anne's hand.  While holding the left button, holding the right button allows you to grab and hold onto objects.





Q jumps and A crouches.





Spacebar shoots as usual.  If Anne is holding a gun, it will shoot in the direction the gun is pointing, at the gun's specified strength and rate of fire.  If she isn't holding a gun, she will shoot the same ultra powerful force ray as when there is no player.  Note: if you go camera-free while you have an Anne in the scene, the gun will get shot from Anne's position, not the camera position.





Player keys are due to change in very short order (3/30), and will hopefully include sidestep at the very least.





Object Manipulation





Note that all mouse movement in GUIApp stops when the mouse cursor reaches the edge of the screen.  It can be helpful to move the GUIApp window to the center of your desktop to get more movement range, otherwise you have to pick up the mouse and move it to keep moving objects.





You can select an object by clicking on its green crosshairs.  Selected objects have red crosshairs.  You can select more than one object at once by holding down Ctrl and continuing to click.  Click anywhere else but on a selected crosshair to clear your current selection set.





You can bring the camera to the selected object by pressing Home.  With multiple objects selected, you will go to one of them.  


You can bring the selected object to the position of the camera by pressing Shift-Home.  Again, with multiple objects, it will only bring one of them.


You can bring the light to the camera position by pressing L


You can reset the scene by pressing R: if you have moved things around, this will send them back to their original positions.  It will also (usually) reset things like triggers and gun ammo.


You can reset the GUIApp (getting rid of all currently loaded objects) by pressing Ctrl-R:  Currently, however, this doesn't do a physics system reset, making it rather useless if you go into play mode with terrain or physical objects loaded.





Objects can be moved by holding down the left mouse button and dragging: this will move them in a horizontal plane relative to the camera (not relative to the world).  Hold down Ctrl to change the plane of movement to a vertical one relative to and facing the camera.  Hold down Alt to constrain movement to towards and away from the camera, with no side to side movement.





Objects can be rotated by holding down the right mouse button and dragging: this will allow you to rotate the object around Z and Y: hold down Shift to rotate around X and Y.





Camera Positions





Use the number pad to select a variety of camera angles on the player's position.  These can be very useful to see what the Anne model is doing from outside her body.  Use 5 to return to the default first person camera.  If you find the camera is in a weird state and you don't know why, you may have accidentally hit one of these buttons.  Try hitting 5 just in case.














Menus





GUIApp has a large number of options tucked away under the menus.  An overview of the most often-used options follows - if the option is not covered here, it either is of little interest to non-programmers, or doesn't work:





Settings Menu





Settings>Properties>Camera Properties is used to change the far clipping plane.  This determines how far out GUIApp will draw objects and terrain: the value is in meters, and nothing further away than this will be drawn.  This includes the terrain polygons, so major land features will also disappear when they are beyond the specified distance.  The default is 1000m (1km).





Settings>Rendering>Fog allows you to control how far away and how dense the fog looks: there are only a few options on this dialogue: experiment with them.





Settings>Rendering>Background Settings will let you change the background of the GUIApp to any color you want.  Useful when you are loading a scene but have no sky.





Settings>Rendering>Culling allows you to make objects disappear when they get below a certain size on the screen.  This is useful to make the trees in dense jungle stop rendering beyond where you would notice them while retaining the outline of the distant hills.  It is a better tool for adjusting rendering speed than the far clipping plane.





Settings>System>Virtual Memory Settings is used to create a swap file.  Swap files hold all the textures, mipmaps, and curved bumpmaps which get loaded and created by GUIApp when you first load a groff.  Click on the far left button, 'Go Virtual', to create the swap file.  A swap file is always associated with a particular groff: whenever that groff is loaded again, the swap file will be used if it exists.  If you add objects to a scene after creating a swap file, it will look in the appropriate \Map directory for any maps it can't find in the swap file.





Settings>Terrain>Convert Terrain can turn .trr files (the raw text terrain files produced by the Terrain Exporter MAXScript) into .wtd files (the binary terrain files which GUIApp needs in order to have terrain in a groff).  It pops up a file dialogue, allowing you to find the .trr you want to convert.  Whenever the .wtd format changes, you will need to find all your existing .trrs and reconvert them.





Settings>Terrain>Export triangulation writes out a .tri file, which is a text file that can be loaded back into MAX through the Terrain Exporter MAXScript, to make an exact representation of the game's triangulation of the .wtd file you've handed to it.





View Menu





View>Art Stats: the Art Stats window is a very useful set of information which can tell you how many polygons the GUIApp is currently rendering, your framerate, and even the camera position at your current location, which can be used to find the same location in your MAX file.





View>Stats turns on the full Stats window which has a lot of in depth information on the timings of various game systems.  This is useful to help determine what is taking up most of the frame time in any part of your scene.  It is broken up into categories: the sub items below each category are indented, and their times are added into the total time spent in that category, so you can get a quick sense of the time allocations by glancing at the category totals.  The columns of information are as follows, from left to right: time spent (in milliseconds), the percent of the total time spent that frame, a count (which is used for various different information: in 'Polygons-req', for instance, it means that many polys were considered that frame), and a count per second, which is useful for systems where you are more interested in average throughput than per-frame times, like 'Pixels'.





The stats window can only be turned off by selecting View>Stats again.  Note that if you just close the window by clicking on the X button, it will open again as soon as you enter play mode.





View>Art Stats: gets a framerate counter to print on top of the GUIApp window.  Note that this counter will display a lower fps than the one at the top of the stats window, because the stats window doesn't count the overhead it takes to do various things that we don't do in the shipping game, like printing the stats window itself.





View>Crosshairs: Allows you to control the display of the crosshairs in the edit mode.  Radius allows you to turn off crosshairs beyond a certain distance from you, and the other options are fairly self explanatory.  Note that turning off crosshairs doesn't mean they actually go away: if you click on the position one would be in, it will be selected.  Nonetheless, this can be useful to find an object which is near you.





View>Bounding Volumes: this is mainly of interest to the programmers - it shows the bounding volume of the object as a wireframe (the bounding volume is a box which a lot of rendering and other game calculations are based off of) and draws a bunch of red crosshairs which show how the wrapper is being constructed, a thing which controls how the object gets image cached.  The main reason to use this view as an area creator is because you must have it turned on to see the spatial partitions (below).





View>Spatial Partitions: you can use this to actually see the spatial partitions that the objects are divided into, as purple wireframe boxes.  You must be looking at the bounding volumes for it to work.  Knowing what your spatial partitions look like can be useful in determining how efficient your partition is.





View>Wires: this is a very useful view to see what the exact geometry of your selected object is.  It draws the polygons, using lines of two different colors: light blue means that those faces are considered as flat, purple means they are considered curved.  'Flat' and 'Curved' are usually determined by the method of mapping that was used on the object: non-planar mappings like cylindrical or sphere will almost always result in curved faces.  Curved faces affect two things: how bumpmaps shade across them, and whether GUIApp can merge the faces into larger faces.  If you have a large flat surface like a wall and it is showing many purple edges in the Wires view, it is almost certainly not being as efficient as it needs to be and ought to be remapped.  If you have a flat surface with a lot of blue polygons and it looks like it ought to have less triangles in it, then it probably has non-linear UVW coordinates, which also prevent GUIApp from being able to merge triangles (see the Asset Creation Guidelines document for more info about this).  Note: Wires only shows the wireframe of the currently selected objects.





View>Pinhead: this doesn't have anything to do with Hellraiser: instead it shows the normals on all the vertices of the selected object.  Coupled with the Wires view, it can help you understand why faces are curving or not curving.





View>Bones: use this to see what the solids the physics system is using to represent all objects.  Purple boxes appear around all tangible, sleeping physics solids.  When they are woken up, they become red.  If two boxes are being told to ignore each other physically (this currently only happens when you go to pick something up, to allow the hand solid to penetrate the solid it is grabbing), both boxes will turn green.  





The bones view will also show magnets of various sorts as little axes (three lines, in red, green, and blue), and it will draw a thin, light blue box when you try to pick something up or shoot something, showing the vector which the pickup attempt or gun shot traveled along.  This will remain in the world until you next try to pick something up or shoot a gun.  Note: Bones view will slow down scenes tremendously because every tree has a physical trunk, so you will end up drawing thousands of purple boxes.





View>Terrain Quads shows you the 'quads' or square sections which the terrain system divides the terrain into.  These quads affect both how the terrain polygons get rendered and how they get textured.





View>Triggers makes all triggers visible.  They get rendered as alpha, so if you have a whole lot of them like you do in a full scene, it can get quite slow.





View>Toolbar shows the toolbar which always used to pop up next to the GUIApp.  It is currently off by default (3/30) because most of the buttons on it are fairly useless at this point.





Action Menu





Action>Name Select brings up a dialogue into which you can type an object's entire name (including the instance number, and case is important).  If that name is found, the object will be added to your selection.  This is a useful feature to take yourself to a particular object which would be hard to find otherwise.  It is easier to get the correct object name if you cut-and-paste it from MAX or from the object .lst file which is written out for each groff you load (in the Map directory below the directory you loaded the groff from).





Action>Test Spin makes the camera circle a fixed point.  This can be useful for framerate testing.





Action>Redraw Terrain forces the terrain to update its terrain textures, even when you aren't in play mode.  Occasionally useful for testing terrain textures.





Action>Camera on Player: this and the next four menu choices relate to camera controls.  Generally, you want this to be checked, so that if you bring an Anne into the scene you will actually be using her when you go into play mode.  If there is no Anne in the scene, having this option checked means that when you move the camera about, you are also moving the 'player,' which basically means that things that care about the player position (triggers and raptors, mainly) will think it is where the camera is.  This mode is useful to test things without loading Anne in, but you should always be using Anne anyway.





Action>Camera on Selected: you can look out of a raptor's eyes or get a dizzying view as a box tumbles through the air if you select an object and then turn on Camera on Selected.





Action>Camera Free: this mode lets you move the camera about freely, even if you have Anne loaded.  Occasionally, you will want to have an out-of-body experience and watch Anne from a distance, so that you can move her around with the mouse or watch a raptor attack her from third person instead of first person.





Action>Camera 2m: When you don't have an Anne loaded but you want to see what it would look like to run over the terrain at her eye level, turn this option on.  This only works when Camera Free is on, and unlike Anne, the camera doesn't know how to walk on objects so you won't be able to get to the second floors of buildings.





Action>Turn About World Z: ever "looked up" using the debug movement keys, and then rotated sideways, only to find your view tilting crazily?  Turn on this option to make your view turn left and right relative to the world's Z axis rather than the camera's Z axis.





Action>Partitions takes you to the partition generation window, so that you can make a spatial partition and get the game to run fast.  Basically, you just want to go in here, click on 'Create Best' (Create Fast is disabled, but don't worry, Create Best will create a partition fairly quickly: around 15 minutes on a 266 PII for our scenes with the most objects), and wait until the window says it is done.  Don't forget to save a scene file after you do this or you will have to do it again if you exit!





Options Menu





Options>Controls>Small Move Steps lets you put the debug movement into a mode where you move a lot more slowly, for precise camera positioning.





Options>Controls>Z Only Object Edit makes objects only movable or rotatable around the world Z axis.  Good to move objects up and down without moving them side to side, for getting them just above another object or terrain without accidentally moving them away from the object you are trying to position to.  (It is hard to judge distance from the camera on a 2D screen.)





Options>Physics brings up a menu with a variety of choices for turning the player on or off, and putting objects to sleep (moving objects which come to rest go to 'sleep' until they are touched again so that the physics system doesn't have to process them - sometimes you want to put an object to sleep before it has come to rest for various reasons).





Options>Lighting lets you turn on and off the lighting of objects (making them get darker on the side away from the light source); the fog and shading of objects to match the thickness of the fog near them; and the use of specular lighting.  You almost never want to change these options from their default of 'on.'





Options>Shadows lets you control what shadows are drawn.  Typically, until we make it a default (3/30), you want to turn on Terrain Moving Shadows.  It is a little slower but fairly vital to the look of our game.  Object shadowing does nothing.





Options>Textures>Textures: if you just want to see the geometry and raw bumpmaps of your objects, turn off Textures altogether.  This is most useful to see how well a bumpmap is working: if you don't see clearly defined bumps on your object, or it just looks like a lot of noise, you need to repaint your bumpmap and/or increase the bump strength using text properties.





Options>Textures>Transparency: turning off this option will cause GUIApp to draw blue wherever there is a transparent section of a polygon, instead of drawing it transparently.  It will also show the image caches which are being created by draw black  wherever they would normally be transparent.  Both functions are very crucial: no object should have very much transparency if the player can get very close to it, because drawing a screenful of transparency is slow, yet looks no different than drawing nothing.  Monitoring the size and number of image caches is important as well to get an idea of how well your spatial partitions are working and how well your image cache settings are working.





Options>Textures>Bump: turns bumpmapping on or off, separately from turning texturing on and off.  Mainly useful when you are building an asset to see how much your bumpmaps are enhancing the look of your object.  If they aren't adding a lot visually, they should either be repainted and have their strength changed, or they should be removed.





Options>Textures>Mipmaps: occasionally, you will want to see what your scene or object looks like when it is not being mipmapped.  It should usually look worse: mipmaps are specially constructed lower-resolution versions of maps to be used on polygons that are far enough away on the screen that the full-sized texture map would have to be reduced in scale to fit.  Mipmaps are made to look better than scaled-down textures, and can help avoid moire-patterns and other visual artifacts of texture scaling.





Options>Textures>Mipmap Use: this is a very good setting for speed testing.  256x256 textures are a good deal more slow to render than 128x128 textures, and using lower-res textures will be a detail option for lower end machines.  This menu will let you turn off the largest version of all textures, or even only render the smallest version of all textures.  Surprisingly, especially at a low resolution like 320x200, even the lowest resolution mipmaps can be look good.  Turning off the highest level of mips can also let you know whether you are wasting texture resolution: if you have trouble telling the difference between an object using its highest texture resolution in normal use (which means running around in a scene, playing the game, looking at the object in debug mode all on its own) at 512x384, and the same object using the next highest resolution, that is a good sign that its map resolution is too high, and could be reduced, saving memory and disk space, and increasing rendering speed.





Options>Pixels: there are a few options under this menu which can affect how the game actually draws texture maps.  The only one you will ever want to change in the normal course of area creation is >Filter, which only works on K63D builds, and causes the terrain to be drawn with bilinear filtering in software, which can look pretty nice but costs a little time.





Options>Sorting: again, another menu full of fairly technical settings you don't normally want to mess with.  However, if you are trying to figure out if occlusion planes are working, turning on >Presort Front to Back causes the polygons of the screen to be drawn in the opposite order they are normally drawn in.  This will look really weird, but when you get used to it you can figure out what an occlusion plane is occluding, because those polygons, which would normally be drawn on the top of everything else, won't be drawn at all.  





Options>Image Cache>Cached Render turns on and off image cacheing.  F7 also does this, but it can be easy to forget if it is on or off (although it should be easy to tell by the framerate in a large scene).  The other options under Options>Image Cache are less relevant to ordinary area creation.





Options>Detail Reduction>Enable lets you turn on or off the use of detail reduced objects.  Toggling it on and off can give you some idea of how much speed your detail reduced objects are buying you, but this speed boost will mainly show up in image cache creation times.





Options>Occlusion gives you a few options for determing what exactly gets occluded, which can be useful for debugging your occlusion planes and determining how much speed they are providing.  Normally there is no need to change these settings, however.





Options>Sky lets you turn on and off the sky texture if you have loaded one, whether it fills the entire screen (for now - 3/30 - this is a way to simulate our final proposed sky plan, where the sky bitmap only gets drawn down to the lowest point in the terrain, saving us the cost of drawing the sky behind the terrain on part of the screen.  You can also remove the sky altogether, but once you do that you can't bring it back.





Options>Fast Mode doesn't work too well right now (3/30), but it is supposed to go into a special, flat-shaded no-transparency mode so that you can test physics, AI, and triggers at the best possible framerate.  Testing with all rendering options turned on is a better thing for an area creator to do, however, as you are ultimately responsible for being sure the data you put together can actually all be played without crushing the framerate.





Screen>System Memory: Having System Memory turned on means that GUIApp renders to main RAM, and not video card RAM.  This allows alpha effects to be rendered very quickly, but doing this incurs a fairly large time overhead which we can't afford on machines that don't have a 100Mhz bus or hardware acceleration.  Normally, you want this to be turned off, which means GUIApp is rendering directly into the video card memory, which is a lot faster.  However, a lot of video cards don't come with drivers which allow you to run in video memory under Windows NT.  The Matrox Millenium cards are notable for this.  You can usually get updated drivers off the website, but the default drivers may not allow this.  If you find you can't turn off the System Memory checkmark, try to update your drivers, or else confine your actual framerate testing to Windows 95.


